Beginner's question about csh/tcsh

Jerry McAllister jerrymc at
Thu Apr 15 11:23:45 PDT 2004

> Greetings:
> I have a FreeBSD 4.9-stable server up and running and I ran across an 
> error (most likely mine) while using csh.
> I normally use the UP and DOWN arrow keys to access the command history. 
>    However, this morning instead being able to go through the .history 
> file with the arrow keys (the arrow keys that are not part of the 
> numeric keypad), I get a "^[[A"  when using the up arrow key and a 
> "^[[B" when using the down arrow key.
> I've tried to clear the .history file but I still get it.  I've also 
> tired to google through about 50 doc's and tutorials and through the 
> freebsd-questions archive but... no joy.
> Any hints or questions would be appreciated.  Thank you.

Are you sure your shell was csh/tcsh?
Which account were ou logged in under?   Were you SUed to root?

It sounds like you are using an account with /bin/sh as a shell
or some other one that doesn't know about the tcsh history editing.

For example, unless you change it, root uses sh for a shell.


> Michael Chinn
> _______________________________________________

More information about the freebsd-questions mailing list