AGP Probe problems (5.2.1/5.2/4.9)

Lowell Gilbert freebsd-questions-local at
Sun Apr 11 16:45:32 PDT 2004

"nathan swenson" <nathan_swenson at> writes:

> I'm trying to install FreeBSD for the first time, but I've run into a
> problem. I have tried 4.9, 5.2, and 5.2.1. There are a couple of symptoms
> for what I think are the same problem.
> 1. On booting from the CD, during the machine hangs after the following
> message (I'm guessing it is probing the hardware):
> agp0: <Intel 82443BX (440 BX) host to PCI bridge> mem 0-0xffffffff at
> device 0.0 on pci0
> The same thing happens regardless of which boot option I choose (regular,
> no ACPI, safe, etc).
> So I couldn't install from CD. After some experimentation, I ended up
> booting from the floppy images (apparently the floppy images don't do the
> same stuff to probe the hardware). I was able to install just fine this
> way.
> But when I booted the machine after the install completed, I get the same
> message.
> Can anyone help me? I would really like to use FreeBSD on this machine.
> The hardware is:
> HP NetServer e60
> dual P3-500
> 256mb ram
> SCSI and IDE drives
> I have successfully used Linux (2.2 and 2.4 kernels, RedHat), Solaris, and
> Windows 2000 on this hardware. The AGP implementation may be buggy on the
> hardware, but these other OSes work ok.
> Any ideas?

I had an HP laptop that had similar problems.  [I proved that the AGP
implementation *was* at fault.]  

I worked around it by installing from floppies as you did, and then
booting the fixit disk in order to load the floppy kernel onto the
hard disk.  Once I had a booting kernel on the disk, I was able to
build my own kernel without AGP.

More information about the freebsd-questions mailing list