Install world fails, computer almost unusable

Kris Kennaway kris at
Thu Apr 8 06:15:21 PDT 2004

On Wed, Apr 07, 2004 at 01:45:38PM +0200, Andy Rozman (Aleksander) wrote:
> Hi !
> I succesfully compiled FreeBSD 5.2.1, but problem happened when I wanted to do
> install. After I run installworld install started but halted at one point
> (with copying ld-so.1 in libexec). I found 
> ld-so.1.old file which I removed, and after I run installworld again, mtree
> failed with core dump, and "Bad Syscall"...
> Now I can't do anything. Most of system programs now do core dump. 
> Is there a way to solve this?

Probably only with a binary install (i.e. from sysinstall and boot
media) at this point.  FWIW, it sounds like you did the upgrade
incorrectly, e.g. by trying to installworld before you had built and
booted a new kernel.  Follow the steps documented in the handbook and
in /usr/src/UPDATING next time and you should be fine.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: not available
Url :

More information about the freebsd-questions mailing list