Install world fails, computer almost unusable

Kent Stewart kstewart at
Wed Apr 7 07:19:23 PDT 2004

On Wednesday 07 April 2004 04:45 am, Andy Rozman (Aleksander) wrote:
> Hi !
> I succesfully compiled FreeBSD 5.2.1, but problem happened when I
> wanted to do install. After I run installworld install started but
> halted at one point (with copying ld-so.1 in libexec). I found
> ld-so.1.old file which I removed, and after I run installworld again,
> mtree failed with core dump, and "Bad Syscall"...
> Now I can't do anything. Most of system programs now do core dump.
> Is there a way to solve this?

What were you upgrading to 5.2.1 from. If it was 5.1 or older, then 
there were serious problems if you tried to do an installworld from the 
older kernel. The upgrade to 5.2+ worked if you booted to single user 
mode on the new 5.2+ kernel and then did the installworld.

You can find some of the solutions in the archive of -current. IIRC, 
people were able to use the fixit cd, boot from it, and finish the 
system installation. The other choice I remember is to do a clean 5.2.1 


Kent Stewart
Richland, WA

More information about the freebsd-questions mailing list