DMA issue caused crash and file system inconsistency

Lowell Gilbert freebsd-questions-local at
Sat Nov 22 07:39:53 PST 2003

Bert Lagaisse <bert.lagaisse at> writes:

> I did some stupid newbie things:
> I have 2 cdroms, a plextor 8/4/32A and a 50x aopen cdrom.
> I added the line hw.ata.atapi_dma="1" to loader.conf
> The plextor now uses WDMA2
> The aopen cdrom still uses PIO4 (dma worked under wintendo 2000)
> After I tried to enable DMA (using atacontrol) on my aopen cdrom and
> mounted it, the system crashed (freebsd 4.9-RELEASE)
> result :
> During the reboot i got an error and had to run "fsck"
> I did, and answered yes to all the questions. (kinda stupid, I know)
> The system booted but startx couldn't find /var/log/XFree86.0.log
> It seems that /var/log was completely removed
> mkdir log in /var solved the problem
> What else can I expect after a file system inconsistency ?

A bunch of files are missing, too.  Certainly the log files themselves
(many of which will not be created if they don't exist), possibly

> And how do I solve the cdrom DMA problem ?

Do you need to?  

More information about the freebsd-questions mailing list