DMA issue caused crash and file system inconsistency

Bert Lagaisse bert.lagaisse at
Fri Nov 21 05:28:48 PST 2003


I did some stupid newbie things:

I have 2 cdroms, a plextor 8/4/32A and a 50x aopen cdrom.

I added the line hw.ata.atapi_dma="1" to loader.conf
The plextor now uses WDMA2
The aopen cdrom still uses PIO4 (dma worked under wintendo 2000)

After I tried to enable DMA (using atacontrol) on my aopen cdrom and 
mounted it, the system crashed (freebsd 4.9-RELEASE)

result :

During the reboot i got an error and had to run "fsck"

I did, and answered yes to all the questions. (kinda stupid, I know)

The system booted but startx couldn't find /var/log/XFree86.0.log
It seems that /var/log was completely removed

mkdir log in /var solved the problem

What else can I expect after a file system inconsistency ?

And how do I solve the cdrom DMA problem ?

Bert Lagaisse

K.U.Leuven, Dept. computer science

Celestijnenlaan 200A
3001 Heverlee

Email: bert.lagaisse at
Tel: +32 16 32 78 24

More information about the freebsd-questions mailing list