boot failure on new 4.8 kernel: DPT scsi and SMP

Rick Voland rpvoland at
Tue May 27 17:11:39 PDT 2003

I would welcome any suggestions on a boot problem with an SMP kernel for 
FreeBSD 4.8 (RELENG_4_8 obtained May 21).  GENERIC (uniprocessor) kernel 
works fine and FreeBSD uniprocessor has worked fine on this machine for 
a couple years.  (Opensound now supports SMP, so I'm finally trying the 
SMP kernel.)

I configured an SMP kernel by selecting the flags for APIC and SMP, and 
eliminating CPU types other than my i586  (Pentium 233 MMX).  I made no 
other changes.  I used "make buildkernel KERNCONF=CUSTOM" and "make 
installkernel KERNCONF=CUSTOM" which gave no errors.

Boot with the SMP kernel proceeds normally until it loads the second CPU 
followed by "Waiting 15 seconds for SCSI devices to settle." The 
messages that indicated a start for SMP support are:

APIC_IO: Testing 8254 interrupt delivery
APIC_IO: routing 8254 via IOAPIC #0 intpin 2
SMP: AP CPU #1 Launched!

At that point, both SCSI adapters and both IDE drives had already been 
detected.  Then, there is an abnormally long pause (longer than the 
normal 15 second for SCSI devices to settle) followed by messages that 
look like it's probing 15 scsi IDs (0-14), timing out on each one, and 
then probing again.  The boot finally just stopped with no kernel panic 
or final message.  The GENERIC kernel boots just fine.  I also tried an 
SMP kernel with APM commented out.  I get nearly the same error messages.

Motherboard:  Tyan S1564D with 2 x Pentium 233MMX, 256 MB EDO RAM
Hard drives:  2 x IDE (ad0,ad2); 2 x SCSI (da0,da1) on the DPT PM2044UW
                    (FreeBSD is on first SCSI drive)
SCSI:  DPT PM 2044UW with 2 Seagate UW hard drives (da0,da1) and a
                Plextor cdrom (cd0);
        Adaptec 1542CP with a Yamaha CDRW (cd1), an external Orb
                removable drive (da2),
                and a scanner which is turned off and not used in
Video:  ATI XPERT98

Here is the last page of boot messages for the SMP kernel with APM 
disabled.  At this point, both SCSI cards and the IDE drives have been 
detected, and the system waited 15 seconds for the SCSI devices to 
settle.  Note that the system is probing both SCSI buses.  This is just 
the last page.  There were maybe six lines before these
for probing the Adaptec 1542CP (aha).

(probe20:aha1:0:5:0): INQUIRY CDB: 12 1 80 0 ff 0
(probe20:aha1:0:5:0): ILLEGAL REQUEST asc:24,0
(probe20:aha1:0:5:0): Invalid field in CDB sks:c0,1

(probe0:dpt0:0:0:0): CCB 0xccce2744 - timed out
(probe0:dpt0:0:0:0): CCB 0xccce2744 - timed out CCB already completed
(probe1:dpt0:0:1:0): CCB 0xccce26c8 - timed out
(probe1:dpt0:0:1:0): CCB 0xccce26c8 - timed out CCB already completed
(probe2:dpt0:0:2:0): CCB 0xccce264c - timed out
(probe3:dpt0:0:3:0): CCB 0xccce25d0 - timed out
(probe4:dpt0:0:4:0): CCB 0xccce2554 - timed out
(probe5:dpt0:0:5:0): CCB 0xccce24d8 - timed out
(probe6:dpt0:0:6:0): CCB 0xccce245c - timed out
(probe7:dpt0:0:8:0): CCB 0xccce23e0 - timed out   [note: probe7 & 0:8:0]
(probe8:dpt0:0:9:0): CCB 0xccce2364 - timed out
(probe9:dpt0:0:10:0): CCB 0xccce22e8 - timed out
(probe10:dpt0:0:11:0): CCB 0xccce226c - timed out
(probe11:dpt0:0:12:0): CCB 0xccce21f0 - timed out
(probe12:dpt0:0:13:0): CCB 0xccce2174 - timed out
(probe13:dpt0:0:14:0): CCB 0xccce20f8 - timed out
(probe14:dpt0:0:15:0): CCB 0xccce207c - timed out
(probe0:dpt0:0:0:0): CCB 0xccce2744 - timed out
(probe1:dpt0:0:1:0): CCB 0xccce26c8 - timed out
(probe2:dpt0:0:2:0): CCB 0xccce264c - timed out
(probe3:dpt0:0:3:0): CCB 0xccce25d0 - timed out

There were no further messages while I copied these by hand.
These messages are nearly identical to the messages from the SMP kernel 
with APM, but the hex codes differ by 1 in the 7th position.  For 
example, the last line was 0xccce15d0  for the SMP kernel with APM.

Thanks for any suggestions,

Rick Voland
rpvoland at

More information about the freebsd-questions mailing list