C compiler can't creat executables

Dan Nelson dnelson at allantgroup.com
Thu May 22 20:11:05 PDT 2003

In the last episode (May 22), David Banning said:
> I recently deleted a number of packages in /var/db/pkg I -thought- I didn't
> need. On installing linux_base now I get the following error;
> checking for working makeinfo... found
> checking for gcc... cc
> checking whether the C compiler (cc -O -pipe  ) works... no
> configure: error: installation or configuration problem: C compiler cannot create executables.
> ===>  Script "configure" failed unexpectedly.
>       Please report the problem to nakai at FreeBSD.org [maintainer] and attach
>       the "/usr/ports/archivers/rpm/work/rpm-3.0.6/config.log" including the
>       output of the failure of your make command. Also, it might be a good
>       idea to provide an overview of all packages installed on your system
>       (e.g. an `ls /var/db/pkg`).
> *** Error code 1
> Stop in /usr/ports/archivers/rpm.
> *** Error code 1
> Stop in /usr/ports/emulators/linux_base.
> I tried to compile a simple program which worked fine. How would 
> I go about tracking this problem down?

Take a look at "/usr/ports/archivers/rpm/work/rpm-3.0.6/config.log" and
see why cc is failing.

	Dan Nelson
	dnelson at allantgroup.com

More information about the freebsd-questions mailing list