FW: SCP problems - SOLVED [kinda- see below]

John Straiton jsmailing at clickcom.com
Thu May 22 07:12:44 PDT 2003

-----Original Message-----
From: owner-freebsd-questions at freebsd.org
[mailto:owner-freebsd-questions at freebsd.org] On Behalf Of John Straiton
Sent: Wednesday, May 21, 2003 5:24 PM
To: freebsd-questions at FreeBSD.ORG
Subject: SCP problems

Here's one that I haven't found too much help with today...

2 machines. I have successfully set up the whole id_rsa/authorized_keys
thing so that "testuser" can ssh from HOST1 to HOST2 without being
prompted for a password. Now I'm trying to get scp to work in the same

#su testuser
%ssh HOST2
Last login: Wed May 21 15:01:36 2003 from ...... 
	(etc..works good =)..Then I exit back to HOST1 and try: )

%scp testuser at HOST2:/tmp/file.txt /tmp/
protocol error: mtime.sec not delimited

Umm...say what? The only thing I found in google was something about
setting the TERM variable, so I tried echo $TERM and verified that it
was set to vt100.

OpenSSH_3.5p1 FreeBSD-20030201, SSH protocols 1.5/2.0, OpenSSL

FreeBSD 4.8-STABLE (updated today)
OpenSSH_3.5p1 FreeBSD-20030201, SSH protocols 1.5/2.0, OpenSSL


I found an article in comp.unix.questions talking about how the .cshrc
file might have enviroment preferences before it's interactive shell
checks which would cause the mtime error. Come to find that I had
disabled the shell for the HOST2 as I didn't need that functionality.
With the shell disabled, I would get that error message. With it set, I
can scp just fine.

Would the appropriate setup then be to just have the .cshrc exit as
early as possible that will still allow this to work or what? I really
don't want to worry about people having another avenue into the machine
if possible.

John Straiton
jks at clickcom.com
Clickcom, Inc

More information about the freebsd-questions mailing list