shutdown -p now

Jack L. Stone jackstone at
Wed May 21 07:43:51 PDT 2003

At 08:15 PM 5.21.2003 +0800, Robert Storey wrote:
>On Tue, 20 May 2003 20:46:43 -0500
>"Jack L. Stone" <jackstone at> wrote:
>> At 09:22 AM 5.21.2003 +0800, Robert Storey wrote:
>> >Dear All,
>> >
>> >I'm trying to get my computer to shut down and turn the power off. I'm
>> >aware of the command "shutdown -p now". It doesn't work for me, and
>> >after
>          ================  SNIP =============
>> Don't know why your switch quit, but if your computer can manage the
>> shutdown, you need these:
>> In the kernel
>> # device apm0 at nexus? flags 0x20 #Advanced Power Management
>Dear Jack,
>Thanks for the information. I went ahead and tried that, but when I tried
>to configure the new custom kernel, I got this error message:
> root at sonic:/sys/i386/conf> /usr/sbin/config CUSTOM2
> config: CUSTOM2:156: devices with zero units are not likely to be correct
>I decided to stop there rather than compile a possibly flakey kernel. Is
>this error message anything to worry about, or am I doing something wrong?

Robert: The "device apm0 at nexus? flags 0x20" is the correct statement.
Since it's already in the "lernel conf" file, you just have to uncomment.
The warning would not apply to this unless it applies to some other device
you have with zero.

Best regards,
Jack L. Stone,

SageOne Net
jackstone at

More information about the freebsd-questions mailing list