PPP has a mind of it's own!

RexFelis catlord17 at yahoo.com
Wed May 14 08:00:50 PDT 2003


I am enjoying learning FreeBSD but I have come to
a strange little showstopper for which I can
think of no rational explanation, and find no
information in my researches.

I have FreeBSD 5.0 installed on /dev/ad2s1 and it
runs beautifully.  The installation was
experimental, but as I learned more, I decided I
need more space.  So I cleared out half my first
disk and set up a 15 gig partition for FreeBSD

Strangely enough, though, while the partition on
the second hard drive holds the same OS installed
from the same CD, the two installations are
acting very differently when it comes to
connecting to the internet.

I can connect to the internet through the new
install (I am using PPP), but I seem to be
getting no response whenever I try to do
anything.  Ports can't be fetched, web pages
don't open, and pings never go.  I see that the
lights on the modem flash for both outgoing, and
occasionally returning packets, but nothing else

I tried using dd to copy the partitions from my
old install to my new install, and while that
produced working ppp, it also recreated the exact
size of those partitions.

I tried using 'cp -pRv' to carefully copy the
partition contents across, and that also worked
on the ppp problem, but created a problem with
KDE not loading correctly for anyone but root. 
XFree shows up, but nothing else happens from the
weave-patterned screen.

I have also tried just copying across the
contents of /etc/ppp, but to no avail.

How can it be that I am having such different
responses from PPP on two installs from the same

By the way, for those who would advise me to use
4.x... I have done that, too, and - yep - I have
the same exact problem.

I'm stumped.  Anyone have any ideas?  Please???


Do you Yahoo!?
The New Yahoo! Search - Faster. Easier. Bingo.

More information about the freebsd-questions mailing list