possible bug with sudo/ssh

Joseph freebsd-questions at chubbo.net
Fri May 2 17:45:03 PDT 2003

hello there!

i've been having some difficulty with something while using freebsd. i've just
installed freebsd 5 and intalled sudo from package on the cd along with some
other packages.

when i login to the box directly or via ssh as user1, i can ssh out to other boxes
without difficulty. if the remote host is not in my known_hosts, i'm prompted to
add the key. when i login as user2, i get the same effects, i can ssh to remote

in this situation, user2 is a common user and will not be allowed direct login.
user1 and other users will su to user2 or sudo to user2. anytime i do 'su -
user2' or 'sudo su - user2' and i try to ssh to a remote box (or localhost), i
get "Host key verification failed.". i've also tried just 'su user2' and sudo su

i've tried homedirs that are completely empty thinking it may be the
environment, changing shells, changing uid's. i just dunno what's goin on. i can
send output of ssh -vvv, but maybe i'm being really stupid this week.

i have completely reinstalled freebsd 5 on a new drive and i get the same
results. i've also tried this on other freebsd 5 machines with the same result.
never needed to have this functionality on freebsd 5 but it does work on freebsd 4.

thanks in advance for any pointers.

More information about the freebsd-questions mailing list