Attempting to 'make buildworld' (Makefile problem)

Doug Reynolds mav at
Wed Mar 26 13:19:23 PST 2003

On Wed, 26 Mar 2003 23:24:30 +1100, Adam Carmichael wrote:

>I'm new to CVS, and I've only upgraded FreeBSD a few times via CVS, but each
>time without many hiccups (well no problems this far into the piece).
>But I have to upgrade a machine running FreeBSD 4.6.1-RELEASE-p10 #5 - and I
>have a feeling that the last person to upgrade it may have left something
>out, or failled to do something. Needless to say, I upgraded an exact same
>clone of the box (hardware) from FreeBSD 4.7-RELEASE, and it worked without
>a hitch.
>Now when I run make buildworld I get the following:
>make buildworld
>Makefile:137: *** missing separator.  Stop.
>*** Error code 2
>Stop in /usr/src.
>The same goes for "make upgrade_checks" and "make clean" (and having almost
>no usable c experience, I opened the Makefile in vi, and went to line 137,
>but couldn't understand it), but I decided to compare that Makefile with the
>Makefile on the computer world did build (and install) successfully on -
>there was no difference.
>Does anyone have any ideas I could try? How would I find out if the make
>utility is broken because other applications (like PHP and Apache) compile

this might be extreme, but, myself, personaly, would rm -rf /usr/src
and redownload the whole src and then try.  However, I would first try
removing the OBJ directory (/usr/obj/usr/src)  and try it again 
doug reynolds | the maverick | mav at

More information about the freebsd-questions mailing list