devfs and umass devices

Johnson David DavidJohnson at
Wed Jun 25 11:49:22 PDT 2003

I just upgraded to 5.1-RELEASE last night. I have a Jungsoft Nexdisk USB 
memory stick that is being successfully recognized. Since I want the 
memory stick to be usable by users of group operator, I need the 
/dev/da0s1 device to be mode 0664. Then they can mount the device on 
one of their own directories (via vfs.usermount=1).

Under 5.0, I used rc.devfs to add a ruleset to devfs using the following 
commands. This worked fine:

ruleset 99
rule add path da0s1 mode 664
rule -s 99 applyset

Under 5.1 I tried doing a similar action with devfs.conf:

perm    da0s1   0664

This does not work, and after looking over rc.d/devfs, I realized that 
this only works for devices present at boot time, and not for umass 
devices inserted later.

Is there an accepted means of adding a ruleset using the new rc system? 
Is there another way of doing what I want? I understand that rc.devfs 
is deprecated, so I don't really want to use it unless I have to.



More information about the freebsd-questions mailing list