FreeBSD 5.0 install.... getty won't execute

Lowell Gilbert freebsd-questions-local at
Thu Jun 19 13:02:57 PDT 2003

Lucas Holt <luke at> writes:

> I just "tried" to upgrade from 4.8 stable to 5.0 release using the
> following procedure
> make buildkernel
> (error)
> make buildworld
> make buildkernel (worked this time)
> make installkernel (worked after adding a device hint file)
> reboot
> kernel booted, then it tried to run /usr/libexec/getty and died.  It
> went into a loop and I rebooted.  Now the 5.0 kernel won't boot and
> 4.8 gives me an error about /usr/libexec/getty not loading.
> Is my install toast like I'm thinking?  If so, what did I do wrong?  I
> want to upgrade a server with 4.8 release on it remotely and need to
> perfect the upgrade.

No, you need to boot into single-user mode.  You can (and should)
complete the world install from the raw console in single-user mode.

If you haven't done anything but what you described, you are probably
okay.  The 5.x upgrade requires *close* attention to the upgrade
procedure, which you didn't do.

> btw I did try to compile 5.1 first, but I got errors with the kernel
> and the world (mostly variables were redefined)

That's because you didn't do the buildworld first, as you're supposed
to do.

More information about the freebsd-questions mailing list