make buildworld failed

Matthew Seaman m.seaman at
Wed Jun 11 01:59:06 PDT 2003

On Wed, Jun 11, 2003 at 12:32:27PM +0400, ??????? ?????? wrote:

> I have a problem with "make buildworld" on various FreeBSD systems (4.1,
> 4.4, 4.7).
> On all systems I used CVSUP with next parameters:
> *default
> *default base=/usr
> *default prefix=/usr
> *default release=cvs tag=RELENG_4
> *default delete use-rel-suffix
> #*default compress
> src-all

That looks fine to me.  That should get you the latest 4.8-STABLE
sources.  You should certainly be able to update your 4.7 and 4.4
systems by buildworld from those sources -- you may possibly have to
update the 4.1 system in a couple of steps but don't quote me on that.
> Then, I run "make buildworld" from /usr/src/, and it failed on various
> steps (depending OS-version).
> I read many FAQ and manuals, but can't resolve the problem. :-(

The usual steps to take in this case are:

    # cd /usr/src
    # make cleandir
    # make cleandir                         (Yes: do this twice)
    # make update                           (or cvsup in the usual way)
    # make buildworld buildkernel KERNCONF=FOO

Alternatively you can try blowing away the /usr/obj directory:

    # cd /usr/obj
    # rm -rf *
    # chflags -R 0 .
    # rm -rf *

Then try building again.

If that still doesn't work, then post here with the output of the
'make buildworld' command.  



Dr Matthew J Seaman MA, D.Phil.                       26 The Paddocks
                                                      Savill Way
PGP:         Marlow
Tel: +44 1628 476614                                  Bucks., SL7 1TH UK
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: not available
Url :

More information about the freebsd-questions mailing list