I can't connect to internet. Plz help me

Nathan Kinkade nkinkade at ub.edu.bz
Wed Dec 10 13:43:44 PST 2003

On Wed, Dec 10, 2003 at 01:11:22PM -0800, nil ban wrote:
> Hello,
> I'm a novice linux user currently switched over to freebsd when many
> linux users told me that freebsd is real unix and only slackware is
> somehow matched with it. So I installed feeebsd 4.8 but I am getting
> few problems I can't handle.  Kindly tell me how to do the following ;
> I can't connect to internet.  Plz let me explain that.  I have a
> username and password which my isp gave me to use for having mail and
> surfing internet like trumvect at myispname.net and my mail servers names
> are mail.myisp.com(pop3)and smtp.mail.com.  I tried using kpp and I
> could connect to my isp ( I am telling this because pppd does run )
> but whenever I try to visit a website it doesn't work, browser says
> unknown host.  I even tried xchat, it says something like "have u
> missspelled your host name ?".  I also don't know what  my host name
> is. Whenever I type the command "hostname" in console it displays
> nothing and only cursor reappears. I installed it as it is describe in
> the handbook.  Only thing I have done is place this entry
> "firewall_type=open" in rc.conf. I haven't changed anything in any
> configuration file apart from that. I have written this because it
> seemed the default firewall has got something to do with it but I
> ain't sure.  Please tell me in a step by step procedure so I will be
> able to fix it.. I am gradually being depressed for that.  Here
> telephone charge is very costly and for that I can't stay connected
> and experiment for long.
> Please help me.
> P.S  I also can't send & receive mail using kmail inspite of giving
> all the required parameters.

Do you have DNS name resolution setup correctly on your machine?  Your
ISP should have given you at least one IP address for their DNS
server(s).  Make sure that you place these addresses in your
/etc/resolv.conf file.  Such as:


Also, while kppp tells you that you are connected, try pinging an IP
address instead of the domain name.  hotmail.com is and
microsoft.com is  Alternatively you could just plug
either of the IP addresses into your browser address bar.  If it still
doesn't work then you may be able to rule out a DNS issue.

gpg --keyserver pgp.mit.edu --recv-keys D8527E49
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: not available
Url : http://lists.freebsd.org/pipermail/freebsd-questions/attachments/20031210/e03bea45/attachment.bin

More information about the freebsd-questions mailing list