boot loader won't boot freebsd slice (partially solved)

Nathan Kinkade nkinkade at
Mon Dec 1 12:46:45 PST 2003

On Mon, Dec 01, 2003 at 10:57:49AM -0600, Nathan Kinkade wrote:
> The hard disk in my laptop went bad so I just dropped in a new one and
> did a standard install, putting a small DOS partition at the beginning
> on which to install the thinkpad bios configuration utility.
> For some reason the freebsd bootloader will boot DOS on the first
> slice, but only beeps when I try to boot to the FreeBSD slice.  It would
> seem that the bootloader isn't aware that there is any bootable OS at
> that slice, like maybe the bootblocks on that slice are missing or
> incorrect.  I have already tried a complete reinstall and playing around
> with marking slices as active and not.  I know that the slice is has a
> valid OS because I can use the install disks to boot to that slice.  I
> have also tried using the 'packet' option on boot0cfg to no effect.
> Does anyone have any suggestions?
> Thanks,
> Nathan

Well, the machine boots fine using GRUB, but still won't boot with the
FreeBSD boot loader.  So I suppose I'll continue to use GRUB, but I'm a
little confused as to why the FreeBSD boot0 program isn't working.  It
was previously working on this same laptop with a different hard disk.
So I guess the problem is solved, but I would still welcome any
explanations or suggestions as to what was/is going wrong with the
regular boot0 program.

gpg --keyserver --recv-keys D8527E49
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: not available
Url :

More information about the freebsd-questions mailing list