boot loader won't boot freebsd slice

Nathan Kinkade nkinkade at
Mon Dec 1 08:58:28 PST 2003

The hard disk in my laptop went bad so I just dropped in a new one and
did a standard install, putting a small DOS partition at the beginning
on which to install the thinkpad bios configuration utility.
For some reason the freebsd bootloader will boot DOS on the first
slice, but only beeps when I try to boot to the FreeBSD slice.  It would
seem that the bootloader isn't aware that there is any bootable OS at
that slice, like maybe the bootblocks on that slice are missing or
incorrect.  I have already tried a complete reinstall and playing around
with marking slices as active and not.  I know that the slice is has a
valid OS because I can use the install disks to boot to that slice.  I
have also tried using the 'packet' option on boot0cfg to no effect.
Does anyone have any suggestions?

gpg --keyserver --recv-keys D8527E49
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: not available
Url :

More information about the freebsd-questions mailing list