firewire vs IDE DVD.

Adam K Kirchhoff adamk at
Mon Aug 25 12:57:56 PDT 2003

Me again.

I've grabbed the output from mplayer and the dump from ktrace/kdump and
posted them at: (975 kB) (1 kB)

>From mplayer.txt, you see that it's complaing:

"Couldn't open DVD device: /dev/dvd"

Now /dev/dvd is a symlink to /dev/acd0:

[ adamk at sorrow - /usr/home/adamk ]: ls -l /dev/dvd
lrwxr-xr-x  1 root  wheel  3 Aug 25 15:54 /dev/dvd -> /dev/acd0

And /dev/acd0 looks like:

[ adamk at sorrow - /usr/home/adamk ]: ls -l /dev/acd0
crw-r--r--  1 root  operator  117,   0 Aug 25 15:36 /dev/acd0

Note:  user 'adamk' is part of the 'operator' group.  In addition, I've
tried this as root just in case there's some strange permission thing
going on.  Still no luck.

*Any* ideas?


On Mon, 25 Aug 2003, Adam K Kirchhoff wrote:

> I'm hoping someone can help me out here.
> I recently moved a firewire card and DVD drive that had been in my FreeBSD
> box to another computer.  I replaced it with an IDE DVD drive.  The
> probelm is that now I can't get mplayer or vlc to play any DVDs that had
> previously worked with the firewire drive.
> I have, of course, made sure that /dev/dvd is a symbolic link to /dev/acd0
> instead of /dev/cd0 (as it used to be).  The only difference that I can
> think of is that FreeBSD sees the firewire drive as a scsi drive and sees
> the ide drive as an ide drive.  Is DVD playback just not supported on IDE
> drives on FreeBSD -CURRENT?
> Adam

More information about the freebsd-questions mailing list