/dev/dsp inaccessible

epilogue at attcanada.ca epilogue at attcanada.ca
Tue Aug 19 15:10:52 PDT 2003

On Tue, 19 Aug 2003 01:14:08 -0700 (PDT)
"Tiarnan O'Corrain" <ocorrain at yahoo.com> wrote:

> --- epilogue at attcanada.ca wrote:
> > Hello Tiarnan,
> > 
> > Thanks for your input.  I had already turned off the PNPBIOS option. 
> > I tried your
> > suggestion of recompiling with:   
> > 
> > options         PCI_ENABLE_IO_MODES
> > 
> > Judging by dmesg, it made no difference.  It also did not allow any
> > of the software to access /dev/dsp.  Same error messages as 
> > described in first post.
> Try using MAKEDEV to remake the dsp devices, and check the 
> permissions. Can you play any sound through the device node?
> E.g. cat blah.raw > /dev/dsp ?

have tried remaking the devices more than once (and again just now),
but it hasn't helped.  permissions are rw- for all users.

unfortunately, i don't have an *.raw files to try so i simply tried to
cat somefile.wav > /dev/dsp  (and also to /dev/audio)
both produce sound a screeching sound reminiscent of japanese noise bands   :)

> I had a similar tussle with a Maestro 3 on a HP laptop, but it
> worked in the end. It can be done...
> I've attached my kernel configuration and loader.conf. 
> You might try using using the snd_maestro3_load="YES" instead
> of "maestro" in /boot/loader.conf. Maestro3.c is a driver
> for "Allegro" cards, perhaps a closer fit for your 2E.

snd_maestro_load="YES"  --versus--  snd_maestro3_load="YES"
doesn't seem to make any difference.

i appreciate all your help.  any other suggestions you might have are very welcome.
there MUST be some way to get this working.

also, i am wondering about this...

cat /dev/sndstat
FreeBSD Audio Driver (newpcm)
pcm0: <ESS Technology Maestro-2E> at I/O port 0x1400 irq 5 (4p/0r/4v channels duplex)

note the 4p/0r/4v.  to my knowledge this means that there are 4 channels for playing, 4 virtual
channels and 0 (ie. none) available for recording.

am i misinterpreting this?  is anyone able to record with this card on FBSD 4.8?

> "device sbc" is unnecessary in your kernel config.

removed.  thanks.
> Tiarnan

More information about the freebsd-questions mailing list