FreeBSD v4.8: mount w/ 'input/output error"

Keith Young keith_young at
Sat Aug 16 18:23:13 PDT 2003

I apologize for what is probably a very simple question, but I have not 
been able to mount my cd so as to transfer a file from it to my 
system.  Looking at the /etc/fstab I can see "/dev/acd0c, 
mountpoint=/cdrom, fstype=cd9660, options=ro, noauto, dump=0, 
pass#=0.  From what I could determine these are all defaults.  I have tried 
the following commands: mount cd9660 /dev/acd0c /cdrom; mount -t cd9660 
/dev/acd0c /cdrom; mount cd9660; mount_cd9660 /dev/acd0c /cdrom.  The 
result is always a message "Input/Output error."

I purchased v4.8 on cd's, and had no trouble loading it onto my systems.  I 
booted from floppies (couldn't get bios to boot from cd) and then inserted 
cd to finish installation.  I have tried changing the fstab, eliminating 
the option of noauto, so that the system would mount the cd on startup, but 
I got the same message.  Any help would be greatly appreciated.

Btw, on a previous posting I saw instructions to "ls -l /dev/acd*" and then 
to "cd /dev && rm /dev/acd* && ./MAKEDEV acd0".  Would this have any 
bearing on this situation?


More information about the freebsd-questions mailing list