can't wire down scsi devices

Eric esmith at
Fri Aug 15 12:49:05 PDT 2003

hello.. i'm running 5.1 release and i'm trying to wire down my scsi
devices. I have a fibre channel card in my server and it sees 20 drives on
the FC network. Because the kernel auto-allocates device id's as it finds
devices, my fstab is all wrong if i add or remove a FC drive from the FC
switch. The solution is to "wire-down" my scsi busses and devices. I'm
following all the examples on the topic that i can find, but config keeps
giving me the same error when i try to config my kernel.

I have a Qlogic FC card (device isp) and three Symbios scsi busses (device
sym). camcontrol devlist shows my four scsi busses as follows:
scbus0 on isp0 bus 0
scbus1 on sym0 bus 0
scbus2 on sym1 bus 0
scbus3 on sym2 bus 0

here's what i did:

# cd /sys/i386/conf/

I've added the following lines to TEST:

device isp0
device scbus0 at isp0 bus 0
device scbus1 at sym0 bus 0
device scbus2 at sym1 bus 0
device scbus3 at sym2 bus 0
device da0 at scbus2 target 0
device da1 at scbus0 target 1
device da2 at scbus0 target 2
device da3 at scbus0 target 3

and so on..

when i run config -g TEST i get:
config: TEST:60: devices with zero units are not likely to be correct

I've tried taking out those lines and leaving just one. any one. I get the
same error. If I take out all of them and config it, it passes (it's a
copy of GENERIC at that point).

# uname -a
Mon Aug 11 13:57:55 PDT 2003
shop at i386

This is a fresh install of 5.1. I did not cvsup up to this version.

Please help. I can't put these machines online until i can wire the fibre
channel disks the way I want them.

/eric smith

More information about the freebsd-questions mailing list