Floppy drive confusion

Matthew Emmerton matt at compar.com
Wed Aug 13 22:11:34 PDT 2003

> OK, my fist trime trying to mount a floppy under FreebSD (4.8) isn't going
> well.
> I've looked over the net and I think I have a problem.
> I tried the command:
> mount_msdos /dev/fd0 /mnt
> and variants with the slices added.  In all cases tried so far I get the
> error:
> mount_msdos: /dev/fd0: Device not configured
> Here's where I think the problem lies:  (from my dmesg.boot)
> fdc0: <NEC 72065B or clone> at port 0x3f0-0x3f5,0x3f7 irq 6 drq 2 on isa0
> fdc0: FIFO enabled, 8 bytes threshold
> The significant thing here is, there's no fd0 device after the controller
> detected.  I assume this must be why I can't mount my floppy.  Any idea
how I
> can get fd0 to show up?

Do you have a 'device fd0' line in your kernel config, like this?

device          fdc0    at isa? port IO_FD1 irq 6 drq 2
device          fd0     at fdc0 drive 0

Matt Emmerton

More information about the freebsd-questions mailing list