frustrating *dumb* problem getting php to work under apache

tb tb at
Tue Aug 12 13:49:26 PDT 2003

STimms at (Tue 08/12/03 at 02:24 PM -0600):

> humm, that does sound frustrating and you seem to be doing everything right.

thanks. :) i know that newbie questions can be as frustrating for
(i guess) 'oldbies' as the problems the newbies are having, so a 
fast, positive answer is nice.

> Did you install php or mod_php?


> Are you restarting apache after you change your httpd.conf?

oh yes. w/ and w/o ssl -- same problem.

> Are your php pages .php or .php3 or .php4?

hm, i hadn't tried that. i just duped the and addes those 
etensions -- same problem. :/

i'm gonna feel really stupid when this get solved. but i'll
attach a beer to my thank-you mail to whoever helps! 


> -----Original Message-----
> From: tb [mailto:tb at]
> Sent: Tuesday, August 12, 2003 1:54 PM
> To: freebsd-questions at
> Subject: frustrating *dumb* problem getting php to work under apache
> hi, all --
> i know this is a FAQ; in fact, it's *such* a FAQ that i've found dozens
> and dozens and dozens of FAs -- none of which have worked for me. and i
> *really* have tried before asking here. :/ and if i got djbdns, qmail
> and procmail working with maildir, i can't be too hopeless. or lazy. :)
> the goal: apache + php (under 4.8). the facts: apache, mysql, and php 
> installed nicely. the problem: php doesn't render -- browsers either 
> krash (konqueror), show php code, or ask me if i want DL the unknown 
> document. php renders fine when i look at other sites, and i get the 
> same (i.e., raw code) results looking at my host from an OSX box, so 
> it's a server-config problem. as things stand, my httpd.conf is plain-
> vanilla *except for these two lines...
>      AddType application/x-httpd-php .php
>      AddType application/x-httpd-php-source .phps 
> ~line 634 (maybe relevant because of the order in which various
> items load?). however, httpd.conf is plain-vanilla now because i have
> a loooong set of backed-up variations on it, which have included ex-
> periments like subsets of...
>      LoadModule php_module         modules/
>      LoadModule php3_module        modules/     /* for PHP 3 */
>      LoadModule php4_module        modules/     /* for PHP 4 */
>      LoadModule perl_module        modules/
> ...both inside and outside of <IfDefine SSL> [...] </IfDefine>. and
> i've tried lots of other stuff besides.
> what i have now is an install that works, except for this one pathetic 
> problem, basd on the instrux here -- which worked perfectly:
> i've hunted through /var/log for klews about why it's not working.
> i'd be happy to provide all kind of infodumps, but it seemed like a 
> clear statement of the problem might be a good way to begin. for now,
> the basics:
> uname -a
>      FreeBSD <...> 4.8-RELEASE-p1 FreeBSD 4.8-RELEASE-p1 #0: Sat Aug  9 
>      22:22:39 EDT 2003  <...>:/usr/src/sys/compile/EKB030809  i386
>           -- custom-compiled for pcm support on an i810 :)
> httpd -v
>      Server version: Apache/1.3.27 (Unix)
>      Server built:   Aug 12 2003 13:28:32
> httpd -l
>      Compiled-in modules:
>        http_core.c
>        mod_so.c
>      suexec: disabled; invalid wrapper /usr/local/sbin/suexec
> php -v
>      PHP 4.3.1 (cli) (built: Aug 12 2003 13:36:26)
>      Copyright (c) 1997-2002 The PHP Group
>      Zend Engine v1.3.0, Copyright (c) 1998-2002 Zend Technologies
> openssl version
>      OpenSSL 0.9.7a Feb 19 2003
> any advice would be much appreciated!
> thanks,
> t

More information about the freebsd-questions mailing list