USB2Serial - works with "cu" but fails with "minicom"

Joel CARNAT joel.carnat at
Mon Aug 11 14:38:44 PDT 2003


I have an USB2Serial adapter to connect to my SUNs.
I can't use it with minicom.
But when I use "cu -l /dev/ucom0", I can login/do_things/logout correctly.
I tried Eterm, Xterm and console (in case it matters), from $USER and $ROOT.
I also tried to recompile minicom after "/dev/modem@ -> /dev/ucom0" was done.

I had minicom working on the same laptop running NetBSD...

What would explain minicom fails when cu works ?

Thanks for answers,

**** some hardware/conf infos ***
*** dmesg
ucom0: ATEN International Serial adapter, rev 1.10/0.01, addr 2

*** ls -al /dev/uco* /dev/modem
lrwxr-xr-x  1 root  wheel         10 14 jul 17:47 /dev/modem@ -> /dev/ucom0
crw-rw-rw-  1 uucp  dialer  138, 128 11 aoû 23:27 /dev/ucom0

*** cat /usr/local/etc/minicom/minirc.dfl 
# Fichier généré automatiquement - utilisez « minicom -s »
# pour changer les paramètres
pr port             /dev/ucom0
pu baudrate         9600
pu bits             8
pu parity           N
pu stopbits         1
pu downdir          /mnt/dagobah/download
pu histlines        4096

More information about the freebsd-questions mailing list