ports-supfile file problem

Lowell Gilbert freebsd-questions-local at be-well.no-ip.com
Fri Aug 8 10:50:35 PDT 2003

John DeStefano <deesto at yahoo.com> writes:

> I'm trying to update my ports tree to address some possible solutions
> posted here to another problem.  The command I'm running is:
> # cvsup -g -L 2 /usr/local/etc/cvsup/sup/ports-supfile
> Here's the result:
> Parsing supfile "/usr/local/etc/cvsup/sup/ports-supfile"
> Release not specified for collection "host=ftp3.FreeBSD.org"
> And here's the relevent portion of the file:
> *default host=ftp3.FreeBSD.org
> *default base=/usr
> *default prefix=/usr
> *default release=cvs tag=.
> *default delete use-rel-suffix
> I've also tried simply "cvsup -g -L 2 ports-supfile" and "cvsup
> ports-supfile", which both return the same error.
> I assume this is in relation to the line "*default release=cvs tag=.",
> but I'm following the handbook and the sample file by leaving "tag=.". 
> I also tried changing "." to the correct cvs tag (RELENG_5_0) and got
> the same results.
> What am I doing wrong?

You need a collection name in the file.

More information about the freebsd-questions mailing list