Mouse/X11 Documentation

Frank Jahnke frank at
Fri Aug 1 13:04:28 PDT 2003

I'm writing you this message for assistance in getting my mouse wheel to
work with X11.  Yes, another one of these requests.  I have been through
the documentation (and numerous articles on the web) and yet I still
cannot get it to work.

I am running BSD 4.8 with XFree86 v4.3.0 (downloaded last week, so it
should be a very current version of the latest stable release).  My
window manager is currently Window Maker v0.80.1. The mouse is a
Logitech MouseMan Wheel, which I understand is equivalent to the

With success I have installed support for the mouse using moused for the
console drivers.  I added line allscreens_flags to my rc.conf file for
mouse support on the various virtual consoles.  That works fine.  I can
also use the same three buttons for text selection and pasting in X11.

What I cannot get to work is text scrolling using the wheel.  From
section 11.3 of the FAQ, first there is a description of /etc/XF86Config
(which is now located in /etc/X11/XF86Config) that is for XFree86 v3
only.  I currently have the 4.3 equivalent (see below) with SysMouse
replaced by Auto.  Changing from one to the other did not make a
difference, as far as I could tell.

Moving on to section 11.4 of the FAQ, I have tried without success to
use either moused or the X server for wheel support.  For the former, I
added the moused_flags line and options to rc.conf, as suggested. 
Moving now to Example 11-2, first the caption is incorrect.  It DOES
describe use of XF86Config with moused Translations, does it not?  I
needed to use an Identifier of "Mouse0" instead of "Mouse1", or else X11
would crash (again, see below).

Imwheel was downloaded and installed from the ports collection; the
configuration file moved to ~/.imwheelrc (which was used without
alteration).  No success.

Next I tried to use the X Server to translate wheel events.  The
suggested use of "MouseManPlusPS/2" was not recognized by XFree; since
BSD recognized the mouse type on boot-up, I reverted to "Auto".  Using
the device /dev/psm0 was not successful -- the device was busy, and X11
would not load.  I replaced psm0 with sysmouse.  After imwheel was
loaded, the wheel still did not scroll the screen.

I admit that it is frustrating to find files in different directories,
mislabeled headings in the documentation, and configurations that do not
work as suggested.  It feels to me that XFree86 is new, and has not been
fully incorporated into the various texts.

I am at loss on how best to proceed, and your suggestions would be most

Frank Jahnke, Ph.D.
President, FMJ & Associates
Auburn, CA 95604
frank at


Section "InputDevice"

# Identifier and driver

    Identifier  "Mouse0"
    Driver      "mouse"
    Option      "Protocol" "auto"
    Option      "Device" "/dev/sysmouse"
    Option      "Buttons" "5"
#    Option     "ZAxisMapping" "4 5"
#    Option     "Emulate3Buttons" "No"

# Mouse-speed setting for PS/2 mouse.

     Option "Resolution"        "100"

# When using XQUEUE, comment out the above two lines, and uncomment
# the following line.

#    Option "Protocol"  "Xqueue"

# Baudrate and SampleRate are only for some Logitech mice. In
# almost every case these lines should be omitted.

#    Option "BaudRate"  "9600"
#    Option "SampleRate"        "150"

# Emulate3Buttons is an option for 2-button Microsoft mice
# Emulate3Timeout is the timeout in milliseconds (default is 50ms)

#    Option "Emulate3Buttons"
#    Option "Emulate3Timeout"    "50"

# ChordMiddle is an option for some 3-button Logitech mice

#    Option "ChordMiddle"


More information about the freebsd-questions mailing list