floppy drive problem

Chris Pockele chrisp at belgacom.net
Tue Apr 22 05:55:08 PDT 2003

> >
> > > nomad# dd if=/dev/fd0a /mnt
> > > dd: unknown operand /mnt
> >
> > Incorrect use of dd.
> >
Indeed, this was just a mistake that got copy-pasted along :).

> Notice all Chris's commands address a ufs partition, and the errors come from 
> fd0c -- again a ufs concept. The disk is not set up with ufs but FAT12 so 
> these do not exist.
Using fd0a instead of fd0 works fine on another machine.
And doesn't fd0c mean "the whole disk" anyway?

I tried all commands using fd0 and fd0.1440 this time, but I still get the
same error messages (with "fd0c" in them).

When using fdformat, i get this:
nomad# fdformat /dev/fd0
Format 1440K floppy `/dev/fd0'? (y/n): y
Processing fdformat: ioctl(FD_FORM): Input/output error

(no extra kernel messages this time)
The same happens when using fdformat fd0.1440.
After this, the disk becomes unreadable on another PC, so I have to fdformat it

Note that this was with different disks that are ok on other machines and on the
same machine under dos/windows.  The drive can even format disks under dos,
and running scandisk with surface scan enabled doesn't show any faults.
The same problems appear whether or not the disk is formatted on the machine
itself, or on another one.

> His drive works OK under windows; it is possible but very unlikely there is
> a hardware problem.
> His problem will probably disappear if he uses a suitable device fd0 or 
> fd0.1440 rather than fd0a.
> This also applies in writing an image using dd, but here it might be
> advisable to use the sized device fd0.1440 or the traditional raw device
> rfd0.1440
The problems stay the same ... :( 

More information about the freebsd-questions mailing list