[drm:mga_init] *ERROR* Cannot initialize the agpgart module

Lee Harr missive at hotmail.com
Fri Apr 18 19:24:10 PDT 2003

Trying to get dri working with a Matrox G450
on 4.8-RELEASE

The first thing I tried was the drm-kmod port.

Next, I downloaded the patch from:
and built the module (mga.ko)

agp is built in to the GENERIC kernel, but
I also tried loading the module in loader.conf

I also updated to -STABLE as of 4/17/03 and tried the
same thing again. (but not drm-kmod port again... hmm)

When I try to load mga.ko I get this:

drm0: <Matrox G400/G450 (AGP)> mem 0xe9000000-0xe97fffff,\
0xe8000000-0xe8003fff,0xe4000000-0xe5ffffff irq 11 at device \
0.0 on pci3
error: [drm:mga_init] *ERROR* Cannot initialize the agpgart module.
device_probe_and_attach: drm0 attach returned 12

There is nothing in the dmesg mentioning agp, other than the original
line about the video card:

pci3: <Matrox MGA G400 AGP graphics accelerator> at 0.0 irq 11

so I am worried I might have an "unsupported AGP chipset"
How can I tell for sure one way or the other?

A couple of likely useful sections of scanpci -vv

pci bus 0x0000 cardnum 0x1e function 0x00: vendor 0x10de device 0x01e8
nVidia Corporation nForce2 AGP
  STATUS    0x0220  COMMAND 0x0107
  CLASS     0x06 0x04 0x00  REVISION 0xa2
  HEADER    0x01  LATENCY 0x20
  PRIBUS    0x00  SECBUS 0x03  SUBBUS 0x03
  SECLT     0x20  SECSTATUS 0x2220
  IOBASE    0xf000  IOLIM 0x0fff
  NOPREFETCH_MEMBASE 0xe8000000  MEMLIM 0xeaffffff
  PREFETCH_MEMBASE   0xe4000000  MEMLIM 0xe5ffffff


pci bus 0x0003 cardnum 0x00 function 0x00: vendor 0x102b device 0x0525
Matrox Graphics, Inc. MGA G400 AGP
CardVendor 0x102b card 0x0541 (Matrox Graphics, Inc. Millennium G450 Dual 
  STATUS    0x0290  COMMAND 0x0007
  CLASS     0x03 0x00 0x00  REVISION 0x85
  BIST      0x00  HEADER 0x00  LATENCY 0x20  CACHE 0x08
  BASE0     0xe4000008  addr 0xe4000000  MEM PREFETCHABLE
  BASE1     0xe8000000  addr 0xe8000000  MEM
  BASE2     0xe9000000  addr 0xe9000000  MEM
  MAX_LAT   0x20  MIN_GNT 0x10  INT_PIN 0x01  INT_LINE 0x0b
  BYTE_0    0x20  BYTE_1  0x11  BYTE_2  0x0a  BYTE_3  0x40

but I am not sure what to do with any of that.

So, I have still to try:  ports/drm-kmod/ again after updating
to -STABLE and removing agp from the kernel and just loading
it from the module.

Any other hints appreciated.

Tired of spam? Get advanced junk mail protection with MSN 8. 

More information about the freebsd-questions mailing list