XFree86 4.3.0, mysterious crash

David Fleck dcf at aracnet.com
Fri Apr 11 09:34:51 PDT 2003

On Wed, 9 Apr 2003, Willie Viljoen wrote:
> I've been experiencing mysterious crashes with XFree86 4.3.0 on FreeBSD
> 4.8-STABLE. The problem started occuring as soon as I installed 4.3.0 (with
> a portupgrade, all components have been upgraded)
> The system seems to simply hang completely, it responds to nothing but a
> hardware reset. I have tried with both my ATI Radeon 7500 and my SiS 6326
> AGP, same thing. Other than that, everything works as before.
> Anyone out there had a similar problem?
> Will

Yes, pretty much identical ones.  When I portupgraded to 4.3.0 the system
would lock up hard whenever I tried to use X.  The log file indicated that
the xserver tried to query the video card bios and failed, and this
apparently led to a kernel panic.  4.2.1 works  on the system just fine,
so I just reinstalled the 4.2.1 files from packages and haven't bothered
trying to debug it more.  Check your XFree86 log files and dmesg logs for
Video card is a Radeon 7500 also.

David Fleck
dcf at aracnet.com

More information about the freebsd-questions mailing list