No MAKEDEV in /dev after cvsup and rebuild

Joshua Lokken joshualokken at
Tue Apr 8 21:00:20 PDT 2003

* BSDVault (diesel at wrote:
==> First let me say I am not subscriber to list so please respond directly to
==> me.  
==>   I cvsup my box 2 nights ago 5.0 -> 5.0.    When I tried to remake all
==> devices,  I found that there was no MAKEDEV in /dev which seemed odd.  I
==> then tried to copy the one from /usr/src/etc into /dev which erorred with
==> :Operation not Permitted.  I then checked securelevel which was -1.   I then
==> tried to re make the one in /usr/src/etc with make install which told me
==> MAKEDEV was up to date.  I moved MAKEDEV out of /usr/src/etc and then tried
==> to make MAKEDEV which then said "don?t know how to make MAKEDEV".
==>  I am truly stuck.  Can anyone offer some assistance.
==> Thanks 
==> Ray 

I just saw an earlier post to the same effect, and the answer was
that MAKEDEV no longer exists in 5.0, and has been replaced with
devfs, which makes the device files for you.  Beyond that, I'm no
help ;)


More information about the freebsd-questions mailing list