No MAKEDEV in /dev after cvsup and rebuild

Miguel Mendez flynn at
Tue Apr 8 12:05:12 PDT 2003

On Tue, 08 Apr 2003 14:58:12 -0400
BSDVault <diesel at> wrote:


>   I cvsup my box 2 nights ago 5.0 -> 5.0.    When I tried to remake
>   all
> devices,  I found that there was no MAKEDEV in /dev which seemed odd. 
> I then tried to copy the one from /usr/src/etc into /dev which erorred
> with:Operation not Permitted.  I then checked securelevel which was
> -1.   I then tried to re make the one in /usr/src/etc with make
> install which told me MAKEDEV was up to date.  I moved MAKEDEV out of
> /usr/src/etc and then tried to make MAKEDEV which then said "don¹t
> know how to make MAKEDEV".
>  I am truly stuck.  Can anyone offer some assistance.

devfs is now default for all 5.0 systems, so there's no MAKEDEV anymore.

        Miguel Mendez - flynn at
        GPG Public Key ::
        EnergyHQ ::
	Tired of Spam? ->
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 186 bytes
Desc: not available
Url :

More information about the freebsd-questions mailing list