VMware2 build under -CURRENT ... is Broken?

Garance A Drosihn drosih at rpi.edu
Tue Apr 8 06:26:57 PDT 2003

At 10:41 AM +0200 4/4/03, Alexander Langer wrote:
>Thus spake Danilo Fiorenzano (danilo at telusplanet.net):
>  >  At this point I might try to trace the preprocessor output
>  > during the build process, up to the line where the error
>  > occurs.  As soon as I have some time to work on this, anyway.
>I don't quite get it - is it broken, or is it not?
>It builds fine on my -CURRENT from March, 18, but something might
>have changed, which should be fixed.

As I mentioned in my message:

    It happens that I rebuilt the vmware2 port on my machine
    on March 25th.  That went OK.  Just now [April 3rd] I tried
    a force-rebuild of it, and I see the same error that you
    [Danilo Fiorenzano] reported.  So, it looks like something
    has changed in the system includes, and that is confusing
    the vmware2 port.  (I say "in the system", because the
    vmware2 port itself has not changed since I last built it).

I have not pursued this further, as I have determined that my
brand new PC is new enough that vmware2 simply does not work
on it (neither with stable nor current).  Vmware2 builds fine
on -stable, but does not work.  On -current it was building
fine until sometime after March 25th.

[btw, if anyone does update vmware, note that I sent in:
which just adds a missing like to the pkg_plist file]

Garance Alistair Drosehn            =   gad at gilead.netel.rpi.edu
Senior Systems Programmer           or  gad at freebsd.org
Rensselaer Polytechnic Institute    or  drosih at rpi.edu

More information about the freebsd-questions mailing list