Booting from pst0 hangs

Toerless Eckert eckert at
Sun Apr 6 20:05:27 PDT 2003

Has someone ever managed to boot FreeBSD off a Promise SuperTRAK SX6000
RAID controller ? I tried all options i can think of, but it always
failed: boot0 and boot1 work nicely, but boot2 simply hangs as soon
as it tries to do the first bios read from the array. I am somewhat
suspecting that this is related to the BIOS of that controller being
of low quality. That and/or some bug in boot2 related to it being a btx client
and fiddling around with the protections and thus giving the raid controllers'
bios too hard a time.

- Tried FreeBSD 5.0(release) and 4.8(release) boot1/boot2 - same effect.
- Problem is unrelated to disk being a raid. Same effect happens when
  simply moving a perfectly booting ide disk from a "normal" ide controller
  to the sx6000 (hangs in boot2).
- Windows XP boots fine off the sx6000 (also via FreeBSD boot0). Have not
  tried other OSs like Linux though.
- Tried all "OS" settings in the sx6000 BIOS config. No change.

- Q: Any ideas what i could do ?

- Q: Is btx actually switching to real mode for int 13 ? Could it be
     that there's a bug in that code ?

- Q: Are there any alternatives how i could boot a 4.8 or 5.0 freebsd
     solely from the disk ? (I guess i could try to install a linux and
     then use liloboot, but that also uses the btx code from loader...)


More information about the freebsd-questions mailing list