Problems with SMP on IBM Intellistation with 2 Pentium 2s

Brad Zimmerman bzimmer at
Sun Apr 6 13:05:28 PDT 2003

I'm running an IBM intellistation 6898-18U with 128MB of RAM installed 
and two Intel P2s running at 333MHz. I recently upgraded the box from a 
single P2 266MHz. The box had been running great with the single 266MHz 
processor, so, for the geek factor and the fact that processors are so 
cheap, I decided to spend the $20 and buy two new processors and "max 
the box out." Well, I installed both processors, upgraded the BIOS when 
prompted, and allowed the box's BIOS to essentially automatically set 
up the two processors. The BIOS thinks everything is fine with both 
processors (for what little that is worth). I did change the dip 
switches so that the box is configured for 333Mhz.

Now, the box still runs great under the GENERIC kernel (no SMP 
enabled), or pretty much every other revision I have tried -except- for 
when I enable SMP in the kernel. I turn on the three SMP options listed 
in the kernel (and they were the only three I could find in the LINT 
config). I compile and install the new kernel, reboot and... the box 
freezes up hard shortly after I get the message about it (FreeBSD) 
enabling processor 1. I've run through this several times and with 
several versions of FreeBSD (4.7, 4.8 release candidates, and 4.8). 
They all wedge up, although now, with FreeBSD 4.8, it actually wedges 
earlier than before. 4.8 release candidates locked up about 5 minutes 
after the box was done booting. I could log in on the console and 
everything, but after I tried to do much of anything, the box would 
freeze and that was that.

I'm open to suggestions. I can't guarantee that SMP even works properly 
on this box, as FreeBSD is the only OS I've run on it since installing 
dual processors. If there is a way to test this that I don't know 
about, that would certainly help narrow it down to either a HW problem 
or OS problem.

Now, on that front, I did take both processors out, re-seated them - 
same problem. I went down to one processor and put the "blank" back 
into the 2nd processor slot. The box ran fine. I pulled that processor 
out and put the 2nd one into the slot 0. The box ran fine. Both 
processors seem to work _individually_ but not with SMP.

I did search through the archives of -questsion and -smp and didn't 
find anything too relevant. I've avoided 5.0 since it seemed to me 
that, with only two processors, I shouldn't need 5.0's SMP features. I 
also use the box for things every day and would like it to be 
relatively stable. Honestly, I can live without SMP on the box, I just 
wanted to get it working if I could.

Thank you. If I've left out relevant information, I'll be happy to 
provide it.


More information about the freebsd-questions mailing list