USB Printer

Marc Wiz marc at
Sun Apr 6 09:16:54 PDT 2003

I have been reading Konrad's posts and the replies to the mailing
list regarding getting his HP printer to work.

I also have an HP 656C USB printer.  I am running 4.7-Release.

Like Konrad the kernel does see the printer when it plugged in:

Apr  6 11:06:05 freshaire /kernel: ulpt0: HEWLETT-PACKARD DESKJET 656C, rev 1.10/1.10, addr 2, iclass 7/1

Now here comes the interesting part since I figured it would be a
good idea to start debugging this with a simple setup (no printer
spooler, etc.)  I have tried to do echo "hello there" > /dev/ulpt0
and nothing happens.

It takes about 30 seconds before the command ends.

I have tried this on another system with FreeBSD and the 656C printer
and get the same results.

If I try the echo using Linux the printer works just fine.  I.e. a page is
printed with "hello there".

I then verified I had the proper support in the kernel:

kldstat -v | egrep 'usb|lpt'
                14 ppbus/lpt
                121 ohci/usb
                122 uhci/usb
                127 uhub/ulpt
                130 usb/uhub

The code is compiled into the kernel (not a module)

Any suggestions as to how to proceed?  Are there any driver debug options
that can be enabled either for USB or the printer code?

Marc Wiz
marc at
Yes, that really is my last name.

More information about the freebsd-questions mailing list