Smbfs woes

Jason Stewart jstewart at
Tue Apr 1 10:03:10 PST 2003


I have SMBFS compiled statically into the kernel. With the generic
kernel, I was able to resolve netbios names via broacasts. After I
installed my new kernel, I get a message like this: 

mount_smbfs //mis3 at rlm/mis ./tmpmnt

mount_smbfs: can't get server address: nberr = no interface to broadcast
on and no NBNS server speicified. The only way to get it working is to
specify the IP address with -I.

I didn't have an /etc/nsmb.conf file set up, but as I said before, it
worked via broadcast with the generic kernel. I give up and set up an
/etc/nsmb.conf file (I know I really should have one in the first
place), and define workgroup and nbns in the config file. then I try my 
command again.

mount_smbfs: can't get server address: nberr = no such name. Hmmm... I
know that "rlm" exists because my windows and linux clients are
connecting to it with no problems. I might add that the server is
running samba with nmbd (It's acting as the WINS server).

Attempt Three:
define the server explicitly in /etc/nsmb.conf.
It finally works, although It should have worked before. Also, using a
default password does not seem to work, as the mount_smbfs always asks
me for my password no matter what is in the /etc/nsmb.conf file.

Did I break something when I made a new kernel? Why can smbfs not find a
broadcast interface?

Jason Stewart

More information about the freebsd-questions mailing list