math/R: Build failure after PORTREVISION for shlib change

David Wolfskill david at
Wed Jun 28 19:52:03 UTC 2017

On Wed, Jun 28, 2017 at 04:36:18PM -0300, Joseph Mingrone wrote:
> Hi David,
> So far I haven't been able to reproduce any problems in an
> 11.0-RELEASE-p1 jail.  Could you send your list of port options?  If I
> can't reproduce any issues with the same options turned on, I will ask
> you for a full build log.
> Joseph

Thanks for taking a look.

g1-227(11.1)[2] make -C /usr/ports/math/R showconfig
===> The following configuration options are available for R-3.4.0_1:
     ICU=on: Unicode support via ICU
     INFO=on: GNU info manuals
     LDOUBLE=on: Long double data type
     LETTER=on: US letter paper
     LIBR=on: Shared R library
     MEMPROF=off: Memory profiling via Rprofmem() and tracemem()
     NLS=on: Native Language Support
     RPROF=on: R profiling via Rprof()
     X11=on: X11 graphics device
====> Require GCC
     LTO=on: Use Link Time Optimization
     OPENMP=on: Parallel processing support via OpenMP
====> Require X11
     GHOSTSCRIPT=on: Graphics device for bitmap files via Ghostscript
     JPEG=on: JPEG graphics device
     CAIROPANGO=on: Cairo graphics device and Pango multi-language text
     PNG=on: PNG graphics device
     TCLTK=on: Tcl/Tk GUI toolkit support
     TEXDOCS=on: Build/Install TeX-dependent documentation files
     TIFF=on: TIFF image format support
====> Options available for the single BLAS: you have to select exactly one of them
     ATLAS=off: ATLAS BLAS implementation
     OPENBLAS=off: OpenBLAS BLAS implementation
     NETLIB=off: Netlib BLAS implementation
     RBLAS=on: Use R-bundled BLAS implementation
===> Use 'make config' to modify these settings

I also placed both "normal" and gzipped copies of the typescript
from the (multiple) portmaster runs in
<>; see R.log (or

(I had run portmaster; it built a few things, tried math/R & died.
I re-started portmaster, eliding math/R, but portmaster found it
anyway... though it didn't show up in the list until several other
ports were built successfully.  I then tried again, skipping both
math/R and databases/R-cran-DBI; all of the specified ports built
OK.  Then I tried just math/R & databases/R-cran-DBI; those failed
(as before).  I then specified 'MAKE_JOBS_UNSAFE=yes' in /etc/make.conf
& tried the laast run again; still failed.  Each time, I appended
to the typescript.)

Just in case it's relevant, as /usr/local/bin/gcc-ar5 is from gcc5-5.4.0_2:

g1-227(11.1)[5] make -C /usr/ports/lang/gcc5 showconfig
===> The following configuration options are available for gcc5-5.4.0_2:
     BOOTSTRAP=on: Build using a full bootstrap
     GRAPHITE=off: Support for Graphite loop optimizations
     JAVA=on: Java platform support
===> Use 'make config' to modify these settings

David H. Wolfskill				david at
Do Congress's recent actions on health care qualify as "terrorist acts?"

See for my public key.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 603 bytes
Desc: not available
URL: <>

More information about the freebsd-ports mailing list