Is the kmymoney port broken?

Christian Baer christian.baer at
Wed Mar 23 11:10:16 UTC 2016

On 03/22/16 15:29, Raphael Kubo da Costa wrote:

> CC'ing the list again.

Sorry about that. I'm reading this list via gmane and I pushed the wrong
button. :-)

> It's easy to check: pkg info kdelibs. The version field should say
> 4.14.3_6. If you've just built kmymoney I'd assume it would require that
> new version though. Please also make sure your Mk/ is at
> r411201 or later.

Oh, you were also talking about the version number. God, I really must
have had a bad day with next to no brain activity yesterday!


I rebuilt the kdelibs from the ports and did a make reinstall. After
that I rebuilt KMymoney and the install worked fine. Thanks for your help!

> Yes, I am referring to this commit I made a week ago:
> <>
> Which made kdelibs (and several ports that depend on it) install its
> headers into /usr/local/include/kde4 instead of /usr/local/include.

The reason I was a little skeptical about this at first is because I
tried building KMymoney from souce a couple of months ago too. It didn't
work either (actually stopped at the same point). The reason I didn't
pursue the issue any further at the time was because a truckload of work
was thrown my way shortly after I ran into this and thus put installing
and using KMymoney on hold for a while, since this was more a personal
thing for me.

Now is the second time around I ran into the same problem, so I wasn't
sure if a really recent change could have been the issue.

> You can try recompiling x11/kdelibs4 after making sure both the port and
> are at their latest versions, but I think it should have
> already happened when you tried building kmymoney.

Pretty sure you are right about this considering I completely rebuild
the entire ports tree directly before this.

> A few other things you can try in order to rule out other possibilities:
> - After building kmymoney, run `find work -name importinterface.h' to
>   check where the header was staged.
> - See if resetting your build options (make rmconfig) makes any
>   difference.

I'll make a note of this, but since I got it to work just by rebuilding
the kdelibs, I didn't try any of these things this time round. :-)

> It would also be helpful if you could attach your whole build log if the
> problem persists.

It didn't persist, so thanks again for your help! I really appreciate
you taking the time for this!

Kind regards,

More information about the freebsd-ports mailing list