xfce4 build fails in 10.2 RELEASE: FNF

Margaret scratch65535 at att.net
Mon Mar 14 12:39:08 UTC 2016

Since as yet xfce4 doesn't exist as a package, I tried to build
xfce4 under 10.2 RELEASE using only defaults.  

But the build fails in x11-toolkits because printbackend-cups.so
is not found.  -files.so and -lpr.so exist, but -cups.so does not
That happened AFTER it spent 4.5 hours downloading a whole
gigabyte of tex rubbish that gtk3 apparently wants.  Since all I
wanted at that point was graphics mode and xterm so I could debug
samba more conveniently, I kept deselecting things and
re-starting, trying to avoid having to waste those 4.5 hours. But
nothing worked, and eventually I threw up my hands and let it do
what it wanted -- which was to waste the 4.5 hours and then fail
to build!

I'm absolutely not trying to have a go at Olivier, the
maintainer.  He does yeoman work!  

I'm complaining about the kitchen-sink model that needlessly
prevents coherent subsetting, needlessly steepens every learning
curve, and needlessly makes maintenance harder.  It's perverse
and a violation of Unix principles.

More information about the freebsd-ports mailing list