Unable to upgrade go 1.4 to go 1.5

Peter Jeremy peter at rulingia.com
Fri Sep 25 10:55:13 UTC 2015


I have go-1.4.2,1 installed on a couple of machines and would like to
upgrade to go1.5.  Since go is now completely written in go, go1.5
requires go to bootstrap it.  Unfortunately, the FreeBSD port requires
that lang/go14 is installed in order to install lang/go - even if you
already have go installed.  And lang/go14 is currently forbidden due
to security vulnerabilities.

This is not a good situation.

The various Java ports do a far better job by checking for the
existence of potential bootstrap versions, rather than insisting on
bootstrapping with a specific version.

-- 
Peter Jeremy
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 949 bytes
Desc: not available
URL: <http://lists.freebsd.org/pipermail/freebsd-ports/attachments/20150925/ee9bc1d0/attachment.bin>


More information about the freebsd-ports mailing list