UPDATING 20151006: www/firefox build failure using poudriere

David Wolfskill david at catwhisker.org
Sat Oct 10 15:51:38 UTC 2015

I suspect that there's something fairly fundamental that I'm missing,
that I have something misconfigured (that hasn't shown up in the
biweekly poudriere runs I've been doing since 19 July), or that there's a
bug waiting to bite someone hard in a sensitive place....

On my build machine, I track stable/10 daily; those builds include the
usual "make buildworld" and building the GENERIC kernel that the build
machine itself runs, and also builds the kernels for a couple of other
("client") machines.

Weekly (on Sunday) -- absent some reason to modify this -- I switch the
"client" machines to their "other" boot slices, then install the
(just-built) kernel & userland, and reboot them.  Assuming(!) that none
of their magic smoke leaks at that point, I then stop services that
depend on ports, perform "pkg upgrade", and reboot them -- at which
point they're running a reasonably fresh stable/10 with up-to-date

As I have some ports that require non-default options, I have the client
machinies configured to fetch their packages (exclusively) from the
build machine.

Thus, there's a step I elided from the above description: once the
build machine has rebooted stable/10 successfully on Sunday, it
performs a "poudriere build" to build fresh packages for everything
that needs it on tyhe client machines.  (The build machine itself
and my laptop each get their ports updated using portmaster.)

In order to reduce the time required to build a week's worth of updated
packages, I have the build machine perform a "poudriere build" after the
update to stable/10 on Saturday (which would be today).

I've only been doing this since July, but it's been mostly uneventful
once I got over the initial "learning curve."  Today, however, I
encountered something I wasn't expecting.

The poudriere summary is:
[01:57:51] ====>> Failed ports: www/firefox:configure
[10amd64-ports-home] [2015-10-10_05h46m40s] [committing:] Queued: 374 Built: 373 Failed: 1   Skipped: 0   Ignored: 0   Tobuild: 0    Time: 01:57:48

Examoning the cited log, I find:

checking for SQLITE_ENABLE_DBSTAT_VTAB support in system SQLite... no
configure: error: System SQLite library is not compiled with SQLITE_ENABLE_DBSTAT_VTAB.

Now, because I run firefox on my laptop, I was aware of ports/UPDATING
entry 20151006, which states that the www/firefox build requires
that "databases/sqlite3 port built with DBSTAT option enabled
(default)" -- as this bit me, so I changed the options to match
the recently-changed default in that respect, and was then able to
build www/firefox without further issue (using portmaster, as
mentioned above).

So on the build machine, I tried "poudriere options -p ports
databases/sqlite3" -- but found that the DBSTAT option was enabled.

So I'm a bit confused at this point.

Then it occurred to me that the build machine has devel/subversion
built, and I recalled that subversion also needs databases/sqlite3,
so I checked the option on the version of sqlite3 that is *installed*
on the build machine (vs. the one that poudriere would be building
-- and, I thought, using to resolve dependencies in the built
packages -- and found:

freebeast(10.2-S)[2] cd /usr/ports/databases/sqlite3/
freebeast(10.2-S)[3] make showconfig
===> The following configuration options are available for sqlite3-
     ARMOR=off: Detect misuse of the API
     DBSTAT=off: Enable DBSTAT Virtual Table
     DIRECT_READ=off: File is read directly from disk
     EXTENSION=off: Allow loadable extensions

So: Is poudriere actually failing to build a package because an
installed port on the package-building system doesn't meet the
configuration requirements of the package to be built?

That doesn't make sense to me... but I'll try changing the "installed"
sqlite3 and see if the behavior changes.

David H. Wolfskill				david at catwhisker.org
Those who would murder in the name of God or prophet are blasphemous cowards.

See http://www.catwhisker.org/~david/publickey.gpg for my public key.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 949 bytes
Desc: not available
URL: <http://lists.freebsd.org/pipermail/freebsd-ports/attachments/20151010/29d5d549/attachment.bin>

More information about the freebsd-ports mailing list