cannot build www/webkit-gtk2 (Per olof Ljungmark)

David Wolfskill david at
Mon Jan 5 19:58:02 UTC 2015

On Mon, Jan 05, 2015 at 10:04:10PM +0530, Amit Sengupta wrote:
> I spent 3-4 days trying to build the webkit-gtk2 port on 10.1 RELEASE. I
> kept getting a linker error and I tried every solution I could find about
> it, including trying to change the compiler to use gcc instead of CLANG and
> making a change in the Makefile etc.
> Finally I had a look at the symbols which were generating a linker error
> and I realised they were all to do with 3d graphics. I was not selecting
> the WebGL Option in make config and it was still trying to link those
> routines. So I chose WebGL in make config and the linker didnt fail and I
> was able to finally build the port. Hope this helps others who are stuck
> with webkit-gtk2
> ...


That worked for me, as well -- I figure I probably had disabled that
option in an apparently-misguided effort to reduce(!) the time taken to
build www/webkit-gtk2.


===>>> The following actions were performed:
        Upgrade of webkit-gtk2-1.8.3_7 to webkit-gtk2-2.4.7
        Upgrade of gimp-app-2.8.14,1 to gimp-app-2.8.14_1,1

Script done, output file is portmaster
localhost(10.1-S)[2] echo $?

Thanks again...  I'll update the PR.

David H. Wolfskill				david at
Actions have consequences ... as do inactions.

See for my public key.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 949 bytes
Desc: not available
URL: <>

More information about the freebsd-ports mailing list