Unable to build webkit-gtk2 after updating ICU

Carmel NY carmel_ny at outlook.com
Wed Apr 29 15:04:20 UTC 2015

On Wed, 29 Apr 2015 05:07:20 -0700, David Wolfskill stated:

>I'm no "expert" on Gnome-related things, but (especially since you had
>tried earlier), you might want to re-try the "make" attempt using "make
>clean install" -- within script(1), as you did, as that's almost always
>a Good Idea.

I tried that and virtually every other thing I can think of. It still fails
with this message:

  CXXLD    libWTF.la
  CXXLD    Programs/LLIntOffsetsExtractor
/usr/bin/ld:./.libs/libWTF.a: file format not recognized; treating as linker script
/usr/bin/ld:./.libs/libWTF.a:1: syntax error
c++: error: linker command failed with exit code 1 (use -v to see invocation)
GNUmakefile:40539: recipe for target 'Programs/LLIntOffsetsExtractor' failed
gmake[1]: *** [Programs/LLIntOffsetsExtractor] Error 1
gmake[1]: Leaving directory '/usr/ports/www/webkit-gtk3/work/webkitgtk-2.4.8'
*** Error code 1


More information about the freebsd-ports mailing list