Unable to build webkit-gtk2 after updating ICU

Carmel NY carmel_ny at outlook.com
Wed Apr 29 11:57:58 UTC 2015

While updating ICU as suggested in UPDATING, the "webkit-gtk2" port failed to
build. I have tried several times, including making sure all other ports were
updated. I then removed the port and tried again. It still failed. I even
tried "webkit-gtk3"; however, that failed also.

It fails with this message:

  CXXLD    libWTF.la
  CXXLD    Programs/LLIntOffsetsExtractor
/usr/bin/ld:./.libs/libWTF.a: file format not recognized; treating as linker script
/usr/bin/ld:./.libs/libWTF.a:1: syntax error
c++: error: linker command failed with exit code 1 (use -v to see invocation)
GNUmakefile:40539: recipe for target 'Programs/LLIntOffsetsExtractor' failed
gmake[1]: *** [Programs/LLIntOffsetsExtractor] Error 1
gmake[1]: Leaving directory '/usr/ports/www/webkit-gtk2/work/webkitgtk-2.4.8'
*** Error code 1

make: stopped in /usr/ports/www/webkit-gtk2

The entire build log is located here:


I have posted this on the FreeBSD forum; however, no one has come up with a
solution as of yet. "gnome" is the maintainer, so I know I am never going to
get any help there.


More information about the freebsd-ports mailing list