docbook error persisting

Jeffrey Bouquet jeffreybouquet at
Sun May 25 19:48:23 UTC 2014

I found a PR which was closed with the same error (Its originator had fixed it by reinstalling all ports.)
This persists in dbus, po4a, etc and I reinstalled exactly as UPDATING all docbook, as well as 
a fix someone recently found for it, to the extent it was described.
I'm guessing... the UPDATING docbook leaves out an edge-case step; and/or the error message is too
terse at the xmlto (etc) error lines, etc etc.

I don't consider it urgent here, but would waste time fixing it without probable satisfactory outcome.  So
I'm wondering if anyone can investigate furtther and/or knows a workaround, even manually copying a
file once, somewhere, that satisfies the parsing error(s) and/or loading errors and/or makes them more
precise as to why they occur, a permanent fix, etc...   even removing a minor branch of the /usr/local tree before
reinstalling all suggested docbook entries. 

                    then apply 'msggrep',
                    then convert back to UTF-8 using 'msgconv'.
file:///usr/local/share/xml/catalog.ports:1: parser error : Start tag expected, '<' not found
PUBLIC "-//OASIS//DTD Entity Resolution XML Catalog V1.0//EN" "http://www.oasis-
I/O error : Attempt to load network entity
warning: failed to load external entity ""
cannot parse
Died at line 267.
*** [do-build] Error code 4

Stop in /usr/ports/textproc/po4a.

Script done on Sun May 25 12:36:42 2014

More information about the freebsd-ports mailing list