mail/courier build failures on newer FreeBSD versions

Milan Obuch freebsd-ports at dino.sk
Mon May 26 15:48:09 UTC 2014


On Mon, 26 May 2014 17:23:51 +0200
Dimitry Andric <dim at FreeBSD.org> wrote:

> On 25 May 2014, at 21:38, Milan Obuch <freebsd-ports at dino.sk> wrote:
> > pkg-fallout-builder at FreeBSD.org sends me every other day mails about
> > failing mail/courier build for both 10.0 and 11.0 FreeBSD versions.
> > There is some incompatibility with GCC 4.7, which is used to build
> > mail/courier on systems with system compiler switched to clang. It
> > works, however, with GCC 4.6, this is tested on both 10.0-STABLE and
> > 11.0-CURRENT systems, both i386 and amd64 architectures.
> 
> Please try this diff, which makes mail/courier compile with clang.  I
> also verified that it builds with gcc 4.7 and 4.8.
> 
> -Dimitry

Thanks, I will test it. If it works, no need to use external compiler =
less dependencies... for me, a good thing.

Milan


More information about the freebsd-ports mailing list