USE_PYTHON version range no longer valid?
mike at skew.org
Wed Jan 15 20:10:03 UTC 2014
A port I maintain (sorta) can only be built under Python 2.2.1 through 2.4.x.
The app isn't being developed any longer, so patches to get it to build under
2.5+ aren't likely to be forthcoming.
The port Makefile previously had USE_PYTHON= 2.2-2.4, but it was changed this
week to simply USE_PYTHON=2, with this comment:
- USE_PYTHON* = 2.X -> USE_PYTHON* = 2
- USE_PYTHON* = 2.X+ -> USE_PYTHON* = yes
Reviewed by: python (mva, rm)
Approved by: portmgr-lurkers (mat)
By removing 2.4 as the maximum version, there are inevitable build errors for
Reverting to USE_PYTHON= 2.2-2.4 results in 'make' failing with this:
===> py27-4suite-1.0.b1_1 needs an unsupported version of Python.
I'm fine with that, although I'm unsure what the ramifications are of Python
2.4 being unsupported. Do people have the option of installing Python 2.4.6
and using it with this port, or do we need to decommission the port?
More information about the freebsd-ports