Missing portsnap

LuKreme kremels at kreme.com
Mon Feb 10 16:57:34 UTC 2014


I have a freeBSD 9.2 install that I set up a few months ago and when I went to install the del branch of ntp (postmaster ntp-devel) I get a failure at libiconv:

===>  Cleaning for libiconv-1.14_1
===>  Found saved configuration for libiconv-1.14_1
=> libiconv-1.14.tar.gz doesn't seem to exist in /usr/ports/distfiles//.
=> Attempting to fetch http://ftp.gnu.org/gnu/libiconv/libiconv-1.14.tar.gz
fetch: http://ftp.gnu.org/gnu/libiconv/libiconv-1.14.tar.gz: No address record
=> Attempting to fetch ftp://ftp.gnu.org/gnu/libiconv/libiconv-1.14.tar.gz
fetch: ftp://ftp.gnu.org/gnu/libiconv/libiconv-1.14.tar.gz: No address record
=> Attempting to fetch http://www.gtlib.gatech.edu/pub/gnu/gnu/libiconv/libiconv-1.14.tar.gz
fetch: http://www.gtlib.gatech.edu/pub/gnu/gnu/libiconv/libiconv-1.14.tar.gz: No address record
=> Attempting to fetch http://mirrors.kernel.org/gnu/libiconv/libiconv-1.14.tar.gz
fetch: http://mirrors.kernel.org/gnu/libiconv/libiconv-1.14.tar.gz: No address record
=> Attempting to fetch ftp://ftp.kddlabs.co.jp/GNU/libiconv/libiconv-1.14.tar.gz
fetch: ftp://ftp.kddlabs.co.jp/GNU/libiconv/libiconv-1.14.tar.gz: No address record
=> Attempting to fetch ftp://ftp.dti.ad.jp/pub/GNU/libiconv/libiconv-1.14.tar.gz
fetch: ftp://ftp.dti.ad.jp/pub/GNU/libiconv/libiconv-1.14.tar.gz: No address record
=> Attempting to fetch http://ring.nict.go.jp/archives/GNU/libiconv/libiconv-1.14.tar.gz
fetch: http://ring.nict.go.jp/archives/GNU/libiconv/libiconv-1.14.tar.gz: No address record
=> Attempting to fetch ftp://ftp.mirrorservice.org/sites/ftp.gnu.org/gnu/libiconv/libiconv-1.14.tar.gz
fetch: ftp://ftp.mirrorservice.org/sites/ftp.gnu.org/gnu/libiconv/libiconv-1.14.tar.gz: No address record
=> Attempting to fetch ftp://ftp.informatik.hu-berlin.de/pub/gnu/gnu/libiconv/libiconv-1.14.tar.gz
fetch: ftp://ftp.informatik.hu-berlin.de/pub/gnu/gnu/libiconv/libiconv-1.14.tar.gz: No address record
=> Attempting to fetch ftp://ftp.informatik.rwth-aachen.de/pub/mirror/ftp.gnu.org/pub/gnu/libiconv/libiconv-1.14.tar.gz
fetch: ftp://ftp.informatik.rwth-aachen.de/pub/mirror/ftp.gnu.org/pub/gnu/libiconv/libiconv-1.14.tar.gz: No address record
=> Attempting to fetch http://ftp.funet.fi/pub/gnu/prep/libiconv/libiconv-1.14.tar.gz
fetch: http://ftp.funet.fi/pub/gnu/prep/libiconv/libiconv-1.14.tar.gz: No address record
=> Attempting to fetch ftp://ftp.FreeBSD.org/pub/FreeBSD/ports/distfiles/libiconv-1.14.tar.gz
fetch: ftp://ftp.FreeBSD.org/pub/FreeBSD/ports/distfiles/libiconv-1.14.tar.gz: No address record
=> Couldn't fetch it - please try to retrieve this
=> port manually into /usr/ports/distfiles// and try again.
*** [do-fetch] Error code 1

Stop in /usr/ports/converters/libiconv.
*** [build] Error code 1

So, I tried to updated the ports tree

 # portsnap fetch update
Looking up portsnap.FreeBSD.org mirrors... none found.
Fetching public key from portsnap.FreeBSD.org... failed.
No mirrors remaining, giving up.
 #

The machine is connected to the Internet (I am on the machine via SSH). So now what?

 # ping -c 4 8.8.8.8
PING 8.8.8.8 (8.8.8.8): 56 data bytes
64 bytes from 8.8.8.8: icmp_seq=0 ttl=47 time=21.314 ms
64 bytes from 8.8.8.8: icmp_seq=1 ttl=47 time=21.692 ms
64 bytes from 8.8.8.8: icmp_seq=2 ttl=47 time=21.479 ms
64 bytes from 8.8.8.8: icmp_seq=3 ttl=47 time=21.191 ms

--- 8.8.8.8 ping statistics ---
4 packets transmitted, 4 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 21.191/21.419/21.692/0.188 ms


-- 
"Here comes sunrise. Yeah, here's your sunrise. I used to hide from the
sun, tried to live my whole life underground, why'd you have to rise and
ruin all my fun? Just turn over; close the curtains on the day."



More information about the freebsd-ports mailing list